What are the minimum requirements for the App?

 

The minimum requirements, including supported devices and iOS versions, for the Apple version of the First Southern Mobile App are listed in the iTunes Store as: Requires iOS 7.0 or later. Compatible with iPhone, iPad, and iPod touch. This app is optimized for iPhone 5.

 

Android devices vary, however we try to support all devices. Current minimum requirements for the Android version of the App can be found in the Google Play Store as: Requires Android 4.0 and up


More information on Mobile Banking and links for downloading the mobile app for your device can be found here: Mobile Banking